summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index 713bce5..8b439cb 100644
--- a/common.nix
+++ b/common.nix
@@ -457,8 +457,8 @@ in
# init password
hashedPassword = builtins.readFile "/data/nixos/password.secret";
- # use same keys as my main user
- openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/home/cullmann/.ssh/authorized_keys");
+ # use fixed auth keys
+ openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/data/nixos/authorized_keys.secret");
};
home-manager.users.root = {
@@ -488,6 +488,9 @@ in
# init password
hashedPassword = builtins.readFile "/data/nixos/password.secret";
+
+ # use fixed auth keys
+ openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/data/nixos/authorized_keys.secret");
};
home-manager.users.cullmann = {