summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2024-03-25 19:22:35 +0100
committerChristoph Cullmann <cullmann@kde.org>2024-03-25 19:22:35 +0100
commitf6503be17371b1e13b2e5d25e103f10ee61f57c4 (patch)
tree62e6b2ebf9702c04e927c9fc1105706c13544199 /common.nix
parentdd36203b347f0fb9d4187b75f86fb4486b044162 (diff)
back to btrfs
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index 713bce5..8b439cb 100644
--- a/common.nix
+++ b/common.nix
@@ -457,8 +457,8 @@ in
# init password
hashedPassword = builtins.readFile "/data/nixos/password.secret";
- # use same keys as my main user
- openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/home/cullmann/.ssh/authorized_keys");
+ # use fixed auth keys
+ openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/data/nixos/authorized_keys.secret");
};
home-manager.users.root = {
@@ -488,6 +488,9 @@ in
# init password
hashedPassword = builtins.readFile "/data/nixos/password.secret";
+
+ # use fixed auth keys
+ openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/data/nixos/authorized_keys.secret");
};
home-manager.users.cullmann = {