summaryrefslogtreecommitdiff
path: root/share/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'share/common.nix')
-rw-r--r--share/common.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/share/common.nix b/share/common.nix
index 427e036..b7da76f 100644
--- a/share/common.nix
+++ b/share/common.nix
@@ -232,6 +232,12 @@ in
interval = "weekly";
};
+ # scrub the disks weekly
+ services.btrfs.autoScrub = {
+ enable = true;
+ interval = "weekly";
+ };
+
# avoid suspend ever to be triggered
systemd.targets.sleep.enable = false;
systemd.targets.suspend.enable = false;