summaryrefslogtreecommitdiff
path: root/share/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'share/common.nix')
-rw-r--r--share/common.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/share/common.nix b/share/common.nix
index f7e2803..e458291 100644
--- a/share/common.nix
+++ b/share/common.nix
@@ -100,6 +100,10 @@ in
environment.persistence."/nix/persistent" = {
hideMounts = true;
directories = [
+ # user and group mappings
+ # Either "/var/lib/nixos" has to be persisted, or all users and groups must have a uid/gid specified. The following users are missing a uid
+ "/var/lib/nixos"
+
# systemd timers
{ directory = "/var/lib/systemd/timers"; user = "root"; group = "root"; mode = "u=rwx,g=rx,o=rx"; }
@@ -331,6 +335,11 @@ in
zsh
];
+ # olm is insecure
+ nixpkgs.config.permittedInsecurePackages = [
+ "olm-3.2.16"
+ ];
+
# run browsers in a sandbox
programs.firejail = {
enable = true;