summaryrefslogtreecommitdiff
path: root/share/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'share/common.nix')
-rw-r--r--share/common.nix26
1 files changed, 17 insertions, 9 deletions
diff --git a/share/common.nix b/share/common.nix
index 60ff648..5f16501 100644
--- a/share/common.nix
+++ b/share/common.nix
@@ -409,8 +409,14 @@ in
decompressFonts = true;
};
- # get a small list of curated fonts
+ # system fonts
packages = with pkgs; [
+ # large collection of free fonts
+ google-fonts
+
+ # large collection of patched programming fonts
+ nerdfonts
+
# font families with good unicode coverage as fallback
ibm-plex
noto-fonts
@@ -422,30 +428,32 @@ in
noto-fonts-color-emoji
];
- # use some proper default fonts
+ # proper default config for fonts
fontconfig = {
+ # we use fontconfig
enable = true;
+
+ # use some proper default fonts
defaultFonts = {
emoji = [ "Noto Color Emoji" ];
monospace = [ "MonoLisa" "IBM Plex Mono" "Noto Sans Mono" ];
- sansSerif = [ "Bespoke Sans Variable" "IBM Plex Sans" "Noto Sans" ];
- serif = [ "Bespoke Serif Variable" "IBM Plex Serif" "Noto Serif" ];
+ sansSerif = [ "IBM Plex Sans" "Noto Sans" ];
+ serif = [ "IBM Plex Serif" "Noto Serif" ];
};
- # fixes pixelation
+ # don't look like ancient X11
antialias = true;
- # fixes antialiasing blur
+ # enable proper hinting
hinting = {
enable = true;
style = "full";
- autohint = true;
};
- # makes it bolder
+ # enable proper subpixel handling
subpixel = {
rgba = "rgb";
- lcdfilter = "default";
+ lcdfilter = "light";
};
};
};