summaryrefslogtreecommitdiff
path: root/mini/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mini/hardware-configuration.nix')
-rw-r--r--mini/hardware-configuration.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/mini/hardware-configuration.nix b/mini/hardware-configuration.nix
index e02d525..9adbd15 100644
--- a/mini/hardware-configuration.nix
+++ b/mini/hardware-configuration.nix
@@ -10,18 +10,18 @@
boot.initrd.kernelModules = [ "amdgpu" ];
boot.kernelModules = [ "kvm-amd" ];
- # efi partition
+ # /boot efi partition to boot in UEFI mode
fileSystems."/boot" =
{ device = "/dev/disk/by-id/nvme-CT4000P3PSSD8_2325E6E63746-part1";
fsType = "vfat";
neededForBoot = true;
};
- # vms
- fileSystems."/home/cullmann/vms" =
- { device = "vpool/vms";
- fsType = "zfs";
- depends = [ "/home" ];
+ # /nix encrypted bcachefs for the remaining space
+ fileSystems."/nix" =
+ { device = "/dev/disk/by-id/nvme-CT4000P3PSSD8_2325E6E63746-part2:/dev/disk/by-id/ata-CT2000MX500SSD1_2138E5D5061F";
+ fsType = "bcachefs";
+ neededForBoot = true;
};
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";