summaryrefslogtreecommitdiff
path: root/kuro/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kuro/configuration.nix')
-rw-r--r--kuro/configuration.nix26
1 files changed, 14 insertions, 12 deletions
diff --git a/kuro/configuration.nix b/kuro/configuration.nix
index b8807c8..aaeb0c9 100644
--- a/kuro/configuration.nix
+++ b/kuro/configuration.nix
@@ -14,19 +14,21 @@
/data/nixos/common.nix
];
- # host name
- networking.hostName = "kuro";
+ # amd graphics
+ hardware.opengl.extraPackages = with pkgs; [ amdvlk rocm-opencl-icd rocm-opencl-runtime ];
- # main network interface via systemd-networkd
+ # use systemd-networkd, fixed IPv4, dynamic IPv6
+ networking.hostName = "kuro";
networking.useDHCP = false;
- systemd.network.enable = true;
- systemd.network.networks."10-lan" = {
- matchConfig.Name = "enp2s0";
- networkConfig.DHCP = "yes";
- linkConfig.RequiredForOnline = "routable";
+ networking.nameservers = [ "192.168.13.1" ];
+ systemd.network = {
+ enable = true;
+ networks."10-wan" = {
+ matchConfig.Name = "enp2s0";
+ address = [ "192.168.13.101/24" ];
+ routes = [ { routeConfig.Gateway = "192.168.13.1"; } ];
+ networkConfig.IPv6AcceptRA = true;
+ linkConfig.RequiredForOnline = "routable";
+ };
};
-
- # amd graphics
- hardware.opengl.extraPackages = with pkgs; [ amdvlk rocm-opencl-icd rocm-opencl-runtime ];
- hardware.opengl.extraPackages32 = with pkgs.pkgsi686Linux; [ amdvlk ];
}