summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix23
1 files changed, 20 insertions, 3 deletions
diff --git a/home.nix b/home.nix
index 835dd0b..64ce943 100644
--- a/home.nix
+++ b/home.nix
@@ -2,15 +2,32 @@
# initial version
home.stateVersion = "22.11";
- # ZSH with some nice prompt and extra main user configuration
+ # ZSH with good config
programs.zsh = {
- # zsh with extras wanted
+ # ZSH on
enable = true;
+
+ # we want completion
enableCompletion = true;
+
+ # we want suggestions of already typed stuff
autosuggestion.enable = true;
- history.share = false;
+
+ # we want nice command highlighting
syntaxHighlighting.enable = true;
+ # better history
+ history = {
+ # save timestamps
+ extended = true;
+
+ # kill dupes over full history
+ ignoreAllDups = true;
+
+ # don't share history between sessions
+ share = false;
+ };
+
# aliases
shellAliases = {
# system build/update/cleanup