summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix22
1 files changed, 17 insertions, 5 deletions
diff --git a/home.nix b/home.nix
index 1551346..686ca46 100644
--- a/home.nix
+++ b/home.nix
@@ -39,11 +39,6 @@
verify = "sudo nix --extra-experimental-features nix-command store verify --all";
optimize = "sudo nix --extra-experimental-features nix-command store optimise";
- # overwrite some tools
- cat = "bat";
- ls = "lsd";
- la = "lsd -ahl";
-
# ssh around in the local network
mac = "ssh mac.fritz.box";
macroot = "ssh root@mac.fritz.box";
@@ -85,6 +80,7 @@
# nice cd
programs.zoxide = {
enable = true;
+ enableZshIntegration = true;
options = [ "--cmd" "cd" ];
};
@@ -93,6 +89,22 @@
enable = true;
};
+ # better ls, adds la and Co. aliases, too
+ programs.eza = {
+ enable = true;
+ enableZshIntegration = true;
+ };
+
+ # better cat
+ programs.bat = {
+ enable = true;
+ };
+
+ # better find
+ programs.fd = {
+ enable = true;
+ };
+
# enable keychain, we use the main user key
programs.keychain = {
enable = true;