summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/common.nix b/common.nix
index a0a7a8e..88582f5 100644
--- a/common.nix
+++ b/common.nix
@@ -1,21 +1,17 @@
{ config, pkgs, ... }:
let
impermanence = builtins.fetchTarball "https://github.com/nix-community/impermanence/archive/master.tar.gz";
- home-manager = builtins.fetchTarball "https://github.com/nix-community/home-manager/archive/master.tar.gz";
in
{
#
# stuff shared between home machines
#
- # get impermanence & home manager working
+ # get impermanence working & include more shared parts
imports = [
# manage persistent files
"${impermanence}/nixos.nix"
- # home manager for per user config
- "${home-manager}/nixos"
-
# our users
"/data/nixos/users.nix"
];
@@ -278,12 +274,6 @@ in
systemd.targets.hibernate.enable = false;
systemd.targets.hybrid-sleep.enable = false;
- # let home manager install stuff to /etc/profiles
- home-manager.useUserPackages = true;
-
- # use global pkgs
- home-manager.useGlobalPkgs = true;
-
# allow unfree packages
nixpkgs.config.allowUnfree = true;