summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-07-02 19:54:05 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-07-02 19:54:05 +0200
commitdfee38f4370c8556ec408f081b92b3b9b56f98d6 (patch)
tree1d8a2447315b71c5b7e0cc31bd447dda32561591 /common.nix
parent51983612e19bcd673311645b8527c2f1d74262f2 (diff)
sort home manager settings
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/common.nix b/common.nix
index a0a7a8e..88582f5 100644
--- a/common.nix
+++ b/common.nix
@@ -1,21 +1,17 @@
{ config, pkgs, ... }:
let
impermanence = builtins.fetchTarball "https://github.com/nix-community/impermanence/archive/master.tar.gz";
- home-manager = builtins.fetchTarball "https://github.com/nix-community/home-manager/archive/master.tar.gz";
in
{
#
# stuff shared between home machines
#
- # get impermanence & home manager working
+ # get impermanence working & include more shared parts
imports = [
# manage persistent files
"${impermanence}/nixos.nix"
- # home manager for per user config
- "${home-manager}/nixos"
-
# our users
"/data/nixos/users.nix"
];
@@ -278,12 +274,6 @@ in
systemd.targets.hibernate.enable = false;
systemd.targets.hybrid-sleep.enable = false;
- # let home manager install stuff to /etc/profiles
- home-manager.useUserPackages = true;
-
- # use global pkgs
- home-manager.useGlobalPkgs = true;
-
# allow unfree packages
nixpkgs.config.allowUnfree = true;