summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/common.nix b/common.nix
index 3fad042..ab37b13 100644
--- a/common.nix
+++ b/common.nix
@@ -90,10 +90,15 @@ in
];
};
- #
- # we let the FRITZ!Box do the job
- #
- networking.useDHCP = true;
+ # allow all firmware
+ hardware.enableAllFirmware = true;
+
+ # use systemd-networkd
+ networking.useDHCP = false;
+ networking.useNetworkd = true;
+
+ # ensure firewall is up
+ networking.firewall.enable = true;
# swap to RAM
zramSwap.enable = true;
@@ -268,11 +273,6 @@ in
services.avahi.enable = true;
services.avahi.nssmdns = true;
- # ensure firewall is up
- networking.firewall = {
- enable = true;
- };
-
# let's get SSD status
services.smartd.enable = true;