summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-01-15 22:48:29 +0100
committerChristoph Cullmann <cullmann@kde.org>2023-01-15 22:48:29 +0100
commita3576e284b12bb0cc3080078a528506ec59ac413 (patch)
tree8ed11d5fa47c9729f2b52ca0b7a74553bf136502 /common.nix
parent5d2ad5824d2109a11ed803efda4603d0722767a5 (diff)
use systemd-networkd
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/common.nix b/common.nix
index 3fad042..ab37b13 100644
--- a/common.nix
+++ b/common.nix
@@ -90,10 +90,15 @@ in
];
};
- #
- # we let the FRITZ!Box do the job
- #
- networking.useDHCP = true;
+ # allow all firmware
+ hardware.enableAllFirmware = true;
+
+ # use systemd-networkd
+ networking.useDHCP = false;
+ networking.useNetworkd = true;
+
+ # ensure firewall is up
+ networking.firewall.enable = true;
# swap to RAM
zramSwap.enable = true;
@@ -268,11 +273,6 @@ in
services.avahi.enable = true;
services.avahi.nssmdns = true;
- # ensure firewall is up
- networking.firewall = {
- enable = true;
- };
-
# let's get SSD status
services.smartd.enable = true;