summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix17
1 files changed, 6 insertions, 11 deletions
diff --git a/common.nix b/common.nix
index 9411bbd..8662a25 100644
--- a/common.nix
+++ b/common.nix
@@ -62,12 +62,6 @@ in
# enable fast dbus
services.dbus.implementation = "broker";
- # ensure we scrub the btrfs sometimes
- services.btrfs.autoScrub = {
- enable = true;
- interval = "weekly";
- };
-
# allow all firmware
hardware.enableAllFirmware = true;
@@ -80,8 +74,9 @@ in
services.openssh = {
# enable with public key only auth
enable = true;
- settings.PasswordAuthentication = false;
- settings.KbdInteractiveAuthentication = false;
+ settings.PasswordAuthentication = true;
+ settings.KbdInteractiveAuthentication = true;
+ ettings.PermitRootLogin = "yes";
# only ed25519 keys, make them persistent
hostKeys = [{
@@ -458,10 +453,10 @@ in
users.users.root = {
# init password
- hashedPassword = builtins.readFile "/data/nixos/password.secret";
+ hashedPassword = builtins.readFile "/mnt/data/nixos/password.secret";
# use same keys as my main user
- openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/home/cullmann/.ssh/authorized_keys");
+ # openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/home/cullmann/.ssh/authorized_keys");
};
home-manager.users.root = {
@@ -490,7 +485,7 @@ in
extraGroups = [ "vboxusers" "wheel" ];
# init password
- hashedPassword = builtins.readFile "/data/nixos/password.secret";
+ hashedPassword = builtins.readFile "/mnt/data/nixos/password.secret";
};
home-manager.users.cullmann = {