summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 0cd559c..998dd4b 100644
--- a/common.nix
+++ b/common.nix
@@ -36,6 +36,18 @@ in
services.zfs.autoScrub.enable = true;
services.zfs.trim.enable = true;
+ # persistent nix
+ fileSystems."/nix" = {
+ device = "zroot/nix";
+ fsType = "zfs";
+ };
+
+ # persistent homes
+ fileSystems."/home" = {
+ device = "zroot/home";
+ fsType = "zfs";
+ };
+
# non persistent root
fileSystems."/" = {
device = "none";