summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-01-15 20:43:15 +0100
committerChristoph Cullmann <cullmann@kde.org>2023-01-15 20:43:15 +0100
commit55ccddb352a309a0ff61aa0de6ef494a85b38b71 (patch)
tree916da3f4fd68ddec6629e014af9bc42f79f33caa /common.nix
parent73c8db5b7cadc211bfc84eebded1a2e848abc7af (diff)
more shared fs config
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 0cd559c..998dd4b 100644
--- a/common.nix
+++ b/common.nix
@@ -36,6 +36,18 @@ in
services.zfs.autoScrub.enable = true;
services.zfs.trim.enable = true;
+ # persistent nix
+ fileSystems."/nix" = {
+ device = "zroot/nix";
+ fsType = "zfs";
+ };
+
+ # persistent homes
+ fileSystems."/home" = {
+ device = "zroot/home";
+ fsType = "zfs";
+ };
+
# non persistent root
fileSystems."/" = {
device = "none";