summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/common.nix b/common.nix
index 50c3a90..5b822e2 100644
--- a/common.nix
+++ b/common.nix
@@ -58,13 +58,16 @@ in
# ensure we scrub the btrfs sometimes
services.btrfs.autoScrub = {
enable = true;
- fileSystems = [ "/data" ];
interval = "weekly";
};
# allow all firmware
hardware.enableAllFirmware = true;
+ # use NetworkManager
+ networking.useDHCP = false;
+ networking.networkmanager.enable = true;
+
# ensure firewall is up, allow ssh and http in
networking.firewall.enable = true;
networking.firewall.allowedTCPPorts = [ 22 ];