summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
commit5515e4f5a521b4ebe704278bec3273c8bd639d72 (patch)
tree83b3a85fbf9b434efeefd2525d31cc56ac546ec7 /common.nix
parentb0c5f1e67e5c352d2dbe43eaf136d49a086cd33f (diff)
update config, use NetworkManager
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/common.nix b/common.nix
index 50c3a90..5b822e2 100644
--- a/common.nix
+++ b/common.nix
@@ -58,13 +58,16 @@ in
# ensure we scrub the btrfs sometimes
services.btrfs.autoScrub = {
enable = true;
- fileSystems = [ "/data" ];
interval = "weekly";
};
# allow all firmware
hardware.enableAllFirmware = true;
+ # use NetworkManager
+ networking.useDHCP = false;
+ networking.networkmanager.enable = true;
+
# ensure firewall is up, allow ssh and http in
networking.firewall.enable = true;
networking.firewall.allowedTCPPorts = [ 22 ];