summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index 8b6caf1..ec4d0a2 100644
--- a/common.nix
+++ b/common.nix
@@ -124,8 +124,13 @@ in
];
};
- # ZFS services
- services.zfs.autoScrub.enable = true;
+ # ensure our data is not rotting
+ services.zfs.autoScrub = {
+ enable = true;
+ interval = "weekly";
+ };
+
+ # trim the stuff, we use SSDs
services.zfs.trim.enable = true;
# enable fast dbus