summaryrefslogtreecommitdiff
path: root/beta/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'beta/hardware-configuration.nix')
-rw-r--r--beta/hardware-configuration.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/beta/hardware-configuration.nix b/beta/hardware-configuration.nix
new file mode 100644
index 0000000..8472002
--- /dev/null
+++ b/beta/hardware-configuration.nix
@@ -0,0 +1,29 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+ boot.initrd.kernelModules = [ "amdgpu" ];
+ boot.kernelModules = [ "kvm-amd" ];
+
+ # efi partition
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-id/nvme-CT4000P3PSSD8_2325E6E63746-part1";
+ fsType = "vfat";
+ neededForBoot = true;
+ };
+
+ # vms
+ fileSystems."/home/cullmann/vms" =
+ { device = "vpool/vms";
+ fsType = "zfs";
+ depends = [ "/home" ];
+ };
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}