summaryrefslogtreecommitdiff
path: root/users.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-07-12 20:53:57 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-07-12 20:53:57 +0200
commitc5419a5d6e74d9c6ef2e9620ff2c5284eacd2aa1 (patch)
tree30c3fe7825a76a78cc32d4a5ac32a73d583650ef /users.nix
parent0788d1aa4da22b938960aba4936b5eaf4b36b07e (diff)
sort files
Diffstat (limited to 'users.nix')
-rw-r--r--users.nix69
1 files changed, 0 insertions, 69 deletions
diff --git a/users.nix b/users.nix
deleted file mode 100644
index fde40bf..0000000
--- a/users.nix
+++ /dev/null
@@ -1,69 +0,0 @@
-{ config, pkgs, ... }:
-let
- home-manager = builtins.fetchTarball "https://github.com/nix-community/home-manager/archive/master.tar.gz";
-in
-{
- # get home manager working
- imports = [
- # home manager for per user config
- "${home-manager}/nixos"
- ];
-
- # define the users we have on our systems
- users = {
- # all users and passwords are defined here
- mutableUsers = false;
-
- # default shell is ZSH
- defaultUserShell = pkgs.zsh;
-
- #
- # administrator
- #
-
- users.root = {
- # init password
- hashedPassword = builtins.readFile "/data/nixos/password.secret";
-
- # use fixed auth keys
- openssh.authorizedKeys.keys = pkgs.lib.splitString "\n" (builtins.readFile "/data/nixos/authorized_keys.secret");
- };
-
- #
- # my main user
- #
-
- users.cullmann = {
- # hard code UID for stability over machines
- uid = 1000;
-
- # normal user
- isNormalUser = true;
-
- # it's me :P
- description = "Christoph Cullmann";
-
- # allow VirtualBox and sudo for my main user
- extraGroups = [ "vboxusers" "wheel" ];
-
- # init password
- hashedPassword = config.users.users.root.hashedPassword;
-
- # use fixed auth keys
- openssh.authorizedKeys.keys = config.users.users.root.openssh.authorizedKeys.keys;
- };
- };
-
- # home manager settings
- home-manager = {
- # let home manager install stuff to /etc/profiles
- useUserPackages = true;
-
- # use global pkgs
- useGlobalPkgs = true;
-
- # use shared home manager settings
- users.root = import ./home.nix;
- users.cullmann = import ./home.nix;
- };
-}