summaryrefslogtreecommitdiff
path: root/share/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-09-04 16:50:21 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-09-04 16:50:21 +0200
commitf0d317563c5ccfdd6eec0fd39311e852e5770b23 (patch)
treeb52571199cdd1e3f973607b7afdb8ed51f80f548 /share/common.nix
parent0b70e1608cc6afbdda64bb4df63d1f88c0ea0302 (diff)
try zen kernel
Diffstat (limited to 'share/common.nix')
-rw-r--r--share/common.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/share/common.nix b/share/common.nix
index 81eadc0..2d69673 100644
--- a/share/common.nix
+++ b/share/common.nix
@@ -25,16 +25,13 @@ in
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "23.05"; # Did you read the comment?
- # use the latest kernel
- boot.kernelPackages = pkgs.linuxPackages_latest;
+ # use the ZEN kernel
+ boot.kernelPackages = pkgs.linuxPackages_zen;
# my kernel parameters
boot.kernelParams = [
# don't check for split locks, for KVM and Co.
"split_lock_detect=off"
-
- # avoid that my USB stuff sleeps
- "usbcore.autosuspend=-1"
];
# Use the systemd-boot EFI boot loader.
@@ -507,7 +504,7 @@ in
# enable VirtualBox
virtualisation.virtualbox.host.enable = true;
- #virtualisation.virtualbox.host.enableKvm = true;
+ virtualisation.virtualbox.host.enableKvm = true;
virtualisation.virtualbox.host.enableHardening = false;
virtualisation.virtualbox.host.addNetworkInterface = false;