summaryrefslogtreecommitdiff
path: root/neko/hardware-configuration.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
commit5515e4f5a521b4ebe704278bec3273c8bd639d72 (patch)
tree83b3a85fbf9b434efeefd2525d31cc56ac546ec7 /neko/hardware-configuration.nix
parentb0c5f1e67e5c352d2dbe43eaf136d49a086cd33f (diff)
update config, use NetworkManager
Diffstat (limited to 'neko/hardware-configuration.nix')
-rw-r--r--neko/hardware-configuration.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/neko/hardware-configuration.nix b/neko/hardware-configuration.nix
index 7b59d38..b441981 100644
--- a/neko/hardware-configuration.nix
+++ b/neko/hardware-configuration.nix
@@ -4,14 +4,11 @@
{ config, lib, pkgs, modulesPath, ... }:
{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usbhid" ];
boot.initrd.kernelModules = [ "i915" ];
boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
fileSystems."/" =
{ device = "none";
@@ -85,8 +82,6 @@
options = [ "noatime" "nodiratime" ];
};
- swapDevices = [ ];
-
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}