summaryrefslogtreecommitdiff
path: root/mini/hardware-configuration.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-09-17 15:57:39 +0200
commit5515e4f5a521b4ebe704278bec3273c8bd639d72 (patch)
tree83b3a85fbf9b434efeefd2525d31cc56ac546ec7 /mini/hardware-configuration.nix
parentb0c5f1e67e5c352d2dbe43eaf136d49a086cd33f (diff)
update config, use NetworkManager
Diffstat (limited to 'mini/hardware-configuration.nix')
-rw-r--r--mini/hardware-configuration.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/mini/hardware-configuration.nix b/mini/hardware-configuration.nix
index 2949b75..ae24554 100644
--- a/mini/hardware-configuration.nix
+++ b/mini/hardware-configuration.nix
@@ -4,14 +4,11 @@
{ config, lib, pkgs, modulesPath, ... }:
{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
boot.initrd.kernelModules = [ "amdgpu" ];
boot.kernelModules = [ "kvm-amd" ];
- boot.extraModulePackages = [ ];
fileSystems."/" =
{ device = "none";
@@ -68,8 +65,6 @@
options = [ "noatime" "nodiratime" ];
};
- swapDevices = [ ];
-
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}