summaryrefslogtreecommitdiff
path: root/kuro/hardware-configuration.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-11-27 18:41:49 +0100
committerChristoph Cullmann <cullmann@kde.org>2023-11-27 18:41:49 +0100
commitdb0035dc20b1b83124498ae7558fb782482edaf6 (patch)
tree8fb294a6cb121900abc6acfd3242164ec71b3401 /kuro/hardware-configuration.nix
parent2c9c6c16527c0e26fa281756d629cc01c43b31db (diff)
add new kuro config
Diffstat (limited to 'kuro/hardware-configuration.nix')
-rw-r--r--kuro/hardware-configuration.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/kuro/hardware-configuration.nix b/kuro/hardware-configuration.nix
index 135dacc..26da79b 100644
--- a/kuro/hardware-configuration.nix
+++ b/kuro/hardware-configuration.nix
@@ -20,24 +20,23 @@
};
fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/03B1-533D";
+ { device = "/dev/disk/by-uuid/263D-A89E";
fsType = "vfat";
};
- boot.initrd.luks.devices."crypt-disk1".device = "/dev/disk/by-uuid/3009a0b5-3d8a-48e3-88a7-2a27a928b648";
- boot.initrd.luks.devices."crypt-disk1".allowDiscards = true;
- boot.initrd.luks.devices."crypt-disk1".bypassWorkqueues = true;
+ # system
+ boot.initrd.luks.devices."crypt-system".device = "/dev/disk/by-uuid/f4af1379-93d2-4903-9fb5-5b767d733c66";
fileSystems."/nix" =
- { device = "/dev/mapper/crypt-disk1";
+ { device = "/dev/mapper/crypt-system";
fsType = "btrfs";
- options = [ "subvol=nix" "noatime" "compress=zstd" ];
+ options = [ "subvol=nix" "noatime" "nodiratime" ];
};
fileSystems."/data" =
- { device = "/dev/mapper/crypt-disk1";
+ { device = "/dev/mapper/crypt-system";
fsType = "btrfs";
- options = [ "subvol=data" "noatime" "compress=zstd" ];
+ options = [ "subvol=data" "noatime" "nodiratime" ];
};
fileSystems."/home" =
@@ -58,8 +57,6 @@
options = [ "bind" ];
};
- swapDevices = [ ];
-
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}