summaryrefslogtreecommitdiff
path: root/kuro/hardware-configuration.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2024-01-11 07:37:51 +0100
committerChristoph Cullmann <cullmann@kde.org>2024-01-11 07:37:51 +0100
commit8c8cd2ee042871615f72f5b9a59e6ffabe4edfb9 (patch)
treefee0370e7c7305bea06b4cdcea85b1b56a765a89 /kuro/hardware-configuration.nix
parent56e114ba69399c63bde90cdaf40b567a8da5b39e (diff)
sync configs
Diffstat (limited to 'kuro/hardware-configuration.nix')
-rw-r--r--kuro/hardware-configuration.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/kuro/hardware-configuration.nix b/kuro/hardware-configuration.nix
index 861b7cb..536ea65 100644
--- a/kuro/hardware-configuration.nix
+++ b/kuro/hardware-configuration.nix
@@ -40,19 +40,25 @@
fileSystems."/home" =
{ device = "/data/home";
fsType = "none";
+ neededForBoot = true;
options = [ "bind" ];
+ depends = [ "/data" ];
};
fileSystems."/root" =
{ device = "/data/root";
fsType = "none";
+ neededForBoot = true;
options = [ "bind" ];
+ depends = [ "/data" ];
};
fileSystems."/etc/nixos" =
{ device = "/data/nixos/kuro";
fsType = "none";
+ neededForBoot = true;
options = [ "bind" ];
+ depends = [ "/data" ];
};
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";