summaryrefslogtreecommitdiff
path: root/kuro/configuration.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-06-12 19:32:36 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-06-12 19:32:36 +0200
commit47b005a640a4e2c2729415b15c0b50cb04de6cab (patch)
tree91a950669a9bd32143854f45a536a23cbf47bc64 /kuro/configuration.nix
parent829ebde08fd733dc0abf6f0eab27f45e13ecb6a6 (diff)
fixup kuro config
Diffstat (limited to 'kuro/configuration.nix')
-rw-r--r--kuro/configuration.nix20
1 files changed, 16 insertions, 4 deletions
diff --git a/kuro/configuration.nix b/kuro/configuration.nix
index 07d2abe..b8807c8 100644
--- a/kuro/configuration.nix
+++ b/kuro/configuration.nix
@@ -1,6 +1,6 @@
# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
+# and in the NixOS manual (accessible by running `nixos-help`).
{ config, pkgs, ... }:
@@ -11,10 +11,22 @@
./hardware-configuration.nix
# Shared config of all machines
- /home/cullmann/install/nixos/common.nix
+ /data/nixos/common.nix
];
- # host name & id
+ # host name
networking.hostName = "kuro";
- networking.hostId = "862cf3b5";
+
+ # main network interface via systemd-networkd
+ networking.useDHCP = false;
+ systemd.network.enable = true;
+ systemd.network.networks."10-lan" = {
+ matchConfig.Name = "enp2s0";
+ networkConfig.DHCP = "yes";
+ linkConfig.RequiredForOnline = "routable";
+ };
+
+ # amd graphics
+ hardware.opengl.extraPackages = with pkgs; [ amdvlk rocm-opencl-icd rocm-opencl-runtime ];
+ hardware.opengl.extraPackages32 = with pkgs.pkgsi686Linux; [ amdvlk ];
}