summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-07-02 21:25:41 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-07-02 21:25:41 +0200
commit5d0b02f7b6d72bf3a51b88965c3a03f7da67f5f8 (patch)
tree873bc23c19456c0ad76aae5c12f35c21f0b07366 /home.nix
parent226f60463db2a345c838efc3becc0310adc03177 (diff)
use https://starship.rs/config/ with Dracula
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix26
1 files changed, 24 insertions, 2 deletions
diff --git a/home.nix b/home.nix
index 5e3a99b..1551346 100644
--- a/home.nix
+++ b/home.nix
@@ -55,9 +55,31 @@
};
# nice prompt
- programs.oh-my-posh = {
+ # https://starship.rs/config/
+ # https://draculatheme.com/starship
+ programs.starship = {
enable = true;
- useTheme = "unicorn";
+ enableZshIntegration = true;
+ settings = {
+ aws.style = "bold #ffb86c";
+ cmd_duration.style = "bold #f1fa8c";
+ directory.style = "bold #50fa7b";
+ hostname.style = "bold #ff5555";
+ git_branch.style = "bold #ff79c6";
+ git_status.style = "bold #ff5555";
+ username = {
+ format = "[$user]($style) on ";
+ style_user = "bold #bd93f9";
+ };
+ character = {
+ success_symbol = "[❯](bold #f8f8f2)";
+ error_symbol = "[❯](bold #ff5555)";
+ };
+ directory = {
+ truncation_length = 8;
+ truncate_to_repo = false;
+ };
+ };
};
# nice cd