summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-06-26 18:02:35 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-06-26 18:02:35 +0200
commitfa78f5f7cd58065fc8066b0f9b96bd8708dc8f7d (patch)
treeba6b79358e5491831f6f1560f949c6ee592b77e9 /common.nix
parent4104b8e0a68658193c1d6be607ce663bcc89d870 (diff)
nice prompt
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/common.nix b/common.nix
index 35050f6..0f6df77 100644
--- a/common.nix
+++ b/common.nix
@@ -335,6 +335,7 @@ in
nixos-install-tools
nmap
nvme-cli
+ oh-my-posh
okteta
pkgs.kdePackages.okular
p7zip
@@ -343,7 +344,6 @@ in
pdftk
procs
pulseaudio
- pure-prompt
pwgen
qmk
ripgrep
@@ -587,9 +587,6 @@ in
history.share = false;
syntaxHighlighting.enable = true;
- # use pure prompt
- initExtra = "prompt pure";
-
# aliases
shellAliases = {
# system build/update/cleanup
@@ -615,6 +612,12 @@ in
};
};
+ # nice prompt
+ programs.oh-my-posh = {
+ enable = true;
+ useTheme = "slim";
+ };
+
# nice cd
programs.zoxide = {
enable = true;