summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2024-06-03 22:29:25 +0200
committerChristoph Cullmann <cullmann@kde.org>2024-06-03 22:29:25 +0200
commit97019fee71f269fd705eb473055eb2ff79284378 (patch)
tree47c867a423f7689ee8d15045e3bc9fbd2218e53e /common.nix
parentb38bbd605436edd69f6be1aecfcf03b6517fb8a8 (diff)
sync config
some ZFS tuning and more packages for KDE
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 3e88570..fc0f150 100644
--- a/common.nix
+++ b/common.nix
@@ -29,6 +29,17 @@ in
boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
boot.supportedFilesystems = [ "zfs" ];
+ # don't check for split locks, for KVM and Co.
+ boot.kernelParams = [ "split_lock_detect=off" ];
+
+ # tweak ZFS
+ boot.extraModprobeConfig = ''
+ options zfs zfs_prefetch_disable=1
+ options zfs zfs_arc_max=4294967296
+ options zfs zfs_arc_min=134217728
+ options zfs zfs_arc_meta_limit_percent=75
+ '';
+
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;