summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-10-15 15:33:41 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-10-15 15:33:41 +0200
commit931ca0f4099677c20a462b80ed39da2207ee5185 (patch)
treec27acad22c272764b78063d51510e6a9bd711a5a /common.nix
parent54ee5d5e59ce7fa126bba66f2ecc5bf5ba774459 (diff)
sync config
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix36
1 files changed, 18 insertions, 18 deletions
diff --git a/common.nix b/common.nix
index 61d83fd..9ddf0da 100644
--- a/common.nix
+++ b/common.nix
@@ -281,24 +281,24 @@ in
services.smartd.enable = true;
# ensure cron and Co. can send mails
-# programs.msmtp = {
-# enable = true;
-# setSendmail = true;
-# accounts = {
-# default = {
-# auth = true;
-# tls = true;
-# from = "noreply@home.local";
-# host = "babylon2k.com";
-# port = "587";
-# user = builtins.readFile "/data/nixos/mailuser.secret";
-# password = builtins.readFile "/data/nixos/mailpassword.secret";
-# };
-# };
-# defaults = {
-# aliases = "/etc/aliases";
-# };
-# };
+ programs.msmtp = {
+ enable = true;
+ setSendmail = true;
+ accounts = {
+ default = {
+ auth = true;
+ tls = true;
+ from = "noreply@home.local";
+ host = "babylon2k.com";
+ port = "587";
+ user = builtins.readFile "/data/nixos/mailuser.secret";
+ password = builtins.readFile "/data/nixos/mailpassword.secret";
+ };
+ };
+ defaults = {
+ aliases = "/etc/aliases";
+ };
+ };
environment.etc = {
"aliases" = {