summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-10-21 21:48:11 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-10-21 21:48:11 +0200
commit8df38b9ca655e553985444b2f329e976fd664eea (patch)
treefa628c8d90e99a7363dc1e8a1370935b08242e05 /common.nix
parent653db3e87aa4d9a603d199a47f13978d7cfa66bb (diff)
use systemd-networkd
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/common.nix b/common.nix
index eded544..332e36f 100644
--- a/common.nix
+++ b/common.nix
@@ -64,9 +64,21 @@ in
# allow all firmware
hardware.enableAllFirmware = true;
- # use NetworkManager
+ # use systemd-networkd
networking.useDHCP = false;
- networking.networkmanager.enable = true;
+ systemd.network = {
+ enable = true;
+ networks."10-wan" = {
+ networkConfig = {
+ # start a DHCP Client for IPv4 Addressing/Routing
+ DHCP = "ipv4";
+ # accept Router Advertisements for Stateless IPv6 Autoconfiguraton (SLAAC)
+ IPv6AcceptRA = true;
+ };
+ # make routing on this interface a dependency for network-online.target
+ linkConfig.RequiredForOnline = "routable";
+ };
+ };
# ensure firewall is up, allow ssh and http in
networking.firewall.enable = true;