summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-06-02 23:53:02 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-06-02 23:53:02 +0200
commit64171f58490fc5fbc718236ceda5b53d103eb0a2 (patch)
treeb8da590cc51215c4a4e657f4ad41bf0f25696201 /common.nix
parentf9639193ed25162731a9a04efb765c9c232e84f0 (diff)
improve console setup on boot
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 5486a24..b959dda 100644
--- a/common.nix
+++ b/common.nix
@@ -30,6 +30,15 @@ in
boot.loader.efi.canTouchEfiVariables = true;
boot.loader.efi.efiSysMountPoint = "/boot";
+ # use a high resolution
+ boot.loader.systemd-boot.consoleMode = "max";
+
+ # use systemd early
+ boot.initrd.systemd.enable = true;
+
+ # setup the console stuff early
+ console.earlySetup = true;
+
# zfs & NTFS for Windows stuff
boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
boot.supportedFilesystems = [ "zfs" "ntfs" ];