summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <cullmann@kde.org>2023-04-29 15:51:29 +0200
committerChristoph Cullmann <cullmann@kde.org>2023-04-29 15:51:29 +0200
commit624be0a4d0dc5f2760810143b35a49ba923dcdd5 (patch)
treebd444ab65345d89f6704078e6ed92bb3b90c55a9 /common.nix
parente63568518c575cad878a34e836d5373f77f1ebc5 (diff)
use networkd
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/common.nix b/common.nix
index dd8a2bb..7ed82ab 100644
--- a/common.nix
+++ b/common.nix
@@ -90,6 +90,19 @@ in
# allow all firmware
hardware.enableAllFirmware = true;
+ # networking via networkd
+ systemd.network.enable = true;
+ systemd.network.networks."10-lan" = {
+ networkConfig = {
+ # start a DHCP Client for IPv4 Addressing/Routing
+ DHCP = "ipv4";
+ # accept Router Advertisements for Stateless IPv6 Autoconfiguraton (SLAAC)
+ IPv6AcceptRA = true;
+ };
+ # make routing on this interface a dependency for network-online.target
+ linkConfig.RequiredForOnline = "routable";
+ };
+
# ensure firewall is up, allow ssh and http in
networking.firewall.enable = true;
networking.firewall.allowedTCPPorts = [ 22 80 ];
@@ -133,6 +146,7 @@ in
# X11 settings
services.xserver = {
libinput.enable = true;
+ upscaleDefaultCursor = false;
# Configure keymap in X11
layout = "eu";
@@ -147,9 +161,6 @@ in
enable = true;
displayManager.sddm.enable = true;
displayManager.defaultSession = "plasmawayland";
-
- upscaleDefaultCursor = false;
-
};
# Enable sound with pipewire.
@@ -529,6 +540,7 @@ in
sqlitebrowser
unrar
unzip
+ wine64
xdotool
# retroarch with some emulators