summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
authorChristoph Cullmann <christoph@cullmann.io>2024-07-04 17:11:41 +0200
committerChristoph Cullmann <christoph@cullmann.io>2024-07-04 17:11:41 +0200
commit411a51c074eb75e31f03b8b4db133b14b1318f4d (patch)
treee897e310c691600f3c1ce8a7842b214ccbad6f88 /common.nix
parent7261282a745316021f49e1744bdeac6168080029 (diff)
less DEs, better test that inside VMs
fix keyboard layout
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix22
1 files changed, 10 insertions, 12 deletions
diff --git a/common.nix b/common.nix
index c8bcbd7..0a6ff78 100644
--- a/common.nix
+++ b/common.nix
@@ -195,21 +195,19 @@ in
# allow to have all locales
i18n.supportedLocales = [ "all" ];
- # EurKey layout everywhere
- services.xserver.xkb.layout = "eu";
+ # use X11/wayland layout for console, too
console.useXkbConfig = true;
- # enable SDDM & the KDE Plasma Desktop Environment
- services.xserver.enable = true;
- services.displayManager.sddm.enable = true;
+ # enable greetd & the KDE Plasma Desktop Environment
services.desktopManager.plasma6.enable = true;
- programs.ssh.askPassword = pkgs.lib.mkForce "${pkgs.ksshaskpass.out}/bin/ksshaskpass";
-
- # other desktop environments for testing
- services.xserver.desktopManager.enlightenment.enable = true;
- services.xserver.desktopManager.gnome.enable = true;
- services.xserver.desktopManager.mate.enable = true;
- services.xserver.desktopManager.xfce.enable = true;
+ services.greetd = {
+ enable = true;
+ settings = {
+ default_session = {
+ command = "${pkgs.greetd.tuigreet}/bin/tuigreet --time --cmd '${pkgs.kdePackages.plasma-workspace}/libexec/plasma-dbus-run-session-if-needed ${pkgs.kdePackages.plasma-workspace}/bin/startplasma-wayland'";
+ };
+ };
+ };
# enable sound with PipeWire
sound.enable = true;