summaryrefslogtreecommitdiff
path: root/share/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'share/home.nix')
-rw-r--r--share/home.nix61
1 files changed, 45 insertions, 16 deletions
diff --git a/share/home.nix b/share/home.nix
index 6435985..6a06ef4 100644
--- a/share/home.nix
+++ b/share/home.nix
@@ -2,19 +2,31 @@
# initial version
home.stateVersion = "22.11";
- # my nushell config
- programs.nushell = {
- # we use nushell
+ # ZSH with good config
+ programs.zsh = {
+ # ZSH on
enable = true;
- # shell config
- extraConfig = ''
- $env.config = {
- table: {
- mode: none
- }
- }
- '';
+ # we want completion
+ enableCompletion = true;
+
+ # we want suggestions of already typed stuff
+ autosuggestion.enable = true;
+
+ # we want nice command highlighting
+ syntaxHighlighting.enable = true;
+
+ # better history
+ history = {
+ # save timestamps
+ extended = true;
+
+ # kill dupes over full history
+ ignoreAllDups = true;
+
+ # don't share history between sessions
+ share = false;
+ };
# aliases
shellAliases = {
@@ -42,14 +54,14 @@
neko = "ssh neko.fritz.box";
nekoroot = "ssh root@neko.fritz.box";
};
- };
+ };
# nice prompt
# https://starship.rs/config/
# https://draculatheme.com/starship
programs.starship = {
enable = true;
- enableNushellIntegration = true;
+ enableZshIntegration = true;
settings = {
command_timeout = 10000;
aws.style = "bold #ffb86c";
@@ -76,20 +88,37 @@
# nice cd
programs.zoxide = {
enable = true;
- enableNushellIntegration = true;
+ enableZshIntegration = true;
options = [ "--cmd" "cd" ];
};
+ # integrate fuzzy search
+ programs.fzf = {
+ enable = true;
+ enableZshIntegration = true;
+ };
+
# better completion
programs.carapace = {
enable = true;
- enableNushellIntegration = true;
+ enableZshIntegration = true;
};
# better ls, adds la and Co. aliases, too
programs.eza = {
enable = true;
- enableNushellIntegration = true;
+ enableZshIntegration = true;
+ };
+
+ # tmux replacement
+ programs.zellij = {
+ enable = true;
+ enableZshIntegration = true;
+ settings = {
+ theme = "catppuccin-mocha";
+ pane_frames = false;
+ on_force_close = "quit";
+ };
};
# better cat