summaryrefslogtreecommitdiff
path: root/share/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'share/common.nix')
-rw-r--r--share/common.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/share/common.nix b/share/common.nix
index 2a9d15e..9488e08 100644
--- a/share/common.nix
+++ b/share/common.nix
@@ -332,7 +332,6 @@ in
pkgs.kdePackages.neochat
nixos-install-tools
nmap
- nushell
nvme-cli
procmail
okteta
@@ -499,8 +498,12 @@ in
enableMail = false;
};
- # add nushell and zsh to allowed shells
- environment.shells = with pkgs; [ nushell zsh ];
+ # use ZSH per default
+ programs.zsh.enable = true;
+ environment.shells = with pkgs; [ zsh ];
+
+ # needed for the ZSH completion
+ environment.pathsToLink = [ "/share/zsh" ];
# use micro as default terminal editor
environment.variables.EDITOR = "micro";