summaryrefslogtreecommitdiff
path: root/neko/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'neko/hardware-configuration.nix')
-rw-r--r--neko/hardware-configuration.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/neko/hardware-configuration.nix b/neko/hardware-configuration.nix
index b99622b..f2d229c 100644
--- a/neko/hardware-configuration.nix
+++ b/neko/hardware-configuration.nix
@@ -24,10 +24,21 @@
fsType = "vfat";
};
+ # system
boot.initrd.luks.devices."crypt-system".device = "/dev/disk/by-uuid/2dc54953-958b-4c5a-8454-21c0b1d16222";
boot.initrd.luks.devices."crypt-system".allowDiscards = true;
boot.initrd.luks.devices."crypt-system".bypassWorkqueues = true;
+ # projects
+ boot.initrd.luks.devices."crypt-projects".device = "/dev/disk/by-id/nvme-Samsung_SSD_980_PRO_2TB_S69ENF0R846614L";
+ boot.initrd.luks.devices."crypt-projects".allowDiscards = true;
+ boot.initrd.luks.devices."crypt-projects".bypassWorkqueues = true;
+
+ # vms
+ boot.initrd.luks.devices."crypt-vms".device = "/dev/disk/by-id/nvme-CT2000P5PSSD8_213330E4ED05";
+ boot.initrd.luks.devices."crypt-vms".allowDiscards = true;
+ boot.initrd.luks.devices."crypt-vms".bypassWorkqueues = true;
+
fileSystems."/nix" =
{ device = "/dev/mapper/crypt-system";
fsType = "btrfs";
@@ -58,6 +69,18 @@
options = [ "bind" ];
};
+ fileSystems."/home/cullmann/projects" =
+ { device = "/dev/mapper/crypt-projects";
+ fsType = "btrfs";
+ options = [ "noatime" ];
+ };
+
+ fileSystems."/home/cullmann/vms" =
+ { device = "/dev/mapper/crypt-vms";
+ fsType = "btrfs";
+ options = [ "noatime" ];
+ };
+
swapDevices = [ ];
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";