summaryrefslogtreecommitdiff
path: root/neko/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'neko/hardware-configuration.nix')
-rw-r--r--neko/hardware-configuration.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/neko/hardware-configuration.nix b/neko/hardware-configuration.nix
index 4665392..d0d385a 100644
--- a/neko/hardware-configuration.nix
+++ b/neko/hardware-configuration.nix
@@ -25,13 +25,8 @@
swapDevices = [ ];
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s20f0u4u3.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp8s0.useDHCP = lib.mkDefault true;
+ # Enables DHCP on the right ethernet interface.
+ networking.interfaces.enp8s0.useDHCP = true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";