summaryrefslogtreecommitdiff
path: root/kuro/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kuro/hardware-configuration.nix')
-rw-r--r--kuro/hardware-configuration.nix66
1 files changed, 0 insertions, 66 deletions
diff --git a/kuro/hardware-configuration.nix b/kuro/hardware-configuration.nix
deleted file mode 100644
index 06c2ddb..0000000
--- a/kuro/hardware-configuration.nix
+++ /dev/null
@@ -1,66 +0,0 @@
-# Do not modify this file! It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations. Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
- imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
-
- boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" ];
- boot.initrd.kernelModules = [ "amdgpu" ];
- boot.kernelModules = [ "kvm-amd" ];
-
- fileSystems."/" =
- { device = "none";
- fsType = "tmpfs";
- neededForBoot = true;
- options = [ "defaults" "size=8G" "mode=755" ];
- };
-
- fileSystems."/boot" =
- { device = "/dev/disk/by-id/ata-Samsung_SSD_870_QVO_4TB_S5STNF0W806802J-part1";
- fsType = "vfat";
- neededForBoot = true;
- };
-
- fileSystems."/nix" =
- { device = "/dev/disk/by-id/ata-Samsung_SSD_870_QVO_4TB_S5STNF0W806802J-part2";
- fsType = "bcachefs";
- neededForBoot = true;
- options = [ "noatime" "nodiratime" ];
- };
-
- fileSystems."/data" =
- { device = "/dev/disk/by-id/ata-Samsung_SSD_870_QVO_4TB_S5STNF0W806802J-part3";
- fsType = "bcachefs";
- neededForBoot = true;
- options = [ "noatime" "nodiratime" ];
- };
-
- fileSystems."/home" =
- { device = "/data/home";
- fsType = "none";
- neededForBoot = true;
- options = [ "bind" ];
- depends = [ "/data" ];
- };
-
- fileSystems."/root" =
- { device = "/data/root";
- fsType = "none";
- neededForBoot = true;
- options = [ "bind" ];
- depends = [ "/data" ];
- };
-
- fileSystems."/etc/nixos" =
- { device = "/data/nixos/kuro";
- fsType = "none";
- neededForBoot = true;
- options = [ "bind" ];
- depends = [ "/data" ];
- };
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}