summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 6e40609..500f007 100644
--- a/common.nix
+++ b/common.nix
@@ -123,6 +123,7 @@ in
# keep some stuff persistent
environment.persistence."/nix/persistent" = {
+ hideMounts = true;
directories = [
# systemd timers
{ directory = "/var/lib/systemd/timers"; user = "root"; group = "root"; mode = "u=rwx,g=rx,o=rx"; }
@@ -130,6 +131,9 @@ in
# clamav database
{ directory = "/var/lib/clamav"; user = "clamav"; group = "clamav"; mode = "u=rwx,g=rx,o=rx"; }
];
+ files = [
+ "/etc/machine-id"
+ ];
};
# enable fast dbus