summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 86d0599..58b0199 100644
--- a/common.nix
+++ b/common.nix
@@ -52,6 +52,13 @@ in
];
};
+ # ensure we scrub the btrfs sometimes
+ services.btrfs.autoScrub = {
+ enable = true;
+ fileSystems = [ "/data" ];
+ interval = "weekly";
+ };
+
# allow all firmware
hardware.enableAllFirmware = true;