summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/common.nix b/common.nix
index 9ea74f1..d0440cc 100644
--- a/common.nix
+++ b/common.nix
@@ -67,22 +67,6 @@ in
# allow all firmware
hardware.enableAllFirmware = true;
- # use systemd-networkd
- networking.useDHCP = false;
- systemd.network = {
- enable = true;
- networks."10-wan" = {
- networkConfig = {
- # start a DHCP Client for IPv4 Addressing/Routing
- DHCP = "ipv4";
- # accept Router Advertisements for Stateless IPv6 Autoconfiguraton (SLAAC)
- IPv6AcceptRA = true;
- };
- # make routing on this interface a dependency for network-online.target
- linkConfig.RequiredForOnline = "routable";
- };
- };
-
# ensure firewall is up, allow ssh and http in
networking.firewall.enable = true;
networking.firewall.allowedTCPPorts = [ 22 ];