summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 70ae589..fe0349e 100644
--- a/common.nix
+++ b/common.nix
@@ -130,6 +130,12 @@ in
StateDirectory = "dnscrypt-proxy";
};
+ # block some crap, see https://github.com/StevenBlack/hosts#nixos
+ networking.extraHosts = let
+ hostsPath = https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts;
+ hostsFile = builtins.fetchurl hostsPath;
+ in builtins.readFile "${hostsFile}";
+
# swap to RAM
zramSwap.enable = true;